First item / collection not showing

Hi all-
I minted three NFTs 2 days ago, and when I search for them (or even for my collection) nothing comes up. They won’t appear even on OpenSea.

All my profile is green except for the verification that was missing the header image, which I solved but even so, it is still not verified (but I’ve seen people with non-verified profiles with their items listed)

I really need this resolved or at least understand what happened to try to find a solution.
Thank you if someone can point me in the right direction.

The only solution I have found on the forums was this guy who had to mint it again (!!!):
https://gov.rarible.com/t/minted-my-first-nft-and-nothing-has-happened/8168/9_

Edit: Found it showing that it can’t fetch data on the Creator, the collection shows as Rari, although I have created my own… a mess. I have no idea of what it all means!

2021-06-09 12_07_17-Rarible – Create, sell or collect digital items secured with #blockchain|461x124

Hi @danielbileu

if it’s a “can’t fetch datas”, just wait.

I waited one full week before my NFT appeared.

Just be patient.

Maybe you should share a link to your profile.

1 Like

Thank you, man.
I’ll wait! :slight_smile:

1 Like