Minted Multiple Pieces, broken images

I tried creating a few pieces on Rarible tonight.Went through the whole process of minting, paid the gas fees and the images are broken. Anybody know what’s up or have this problem? Wasted a lot of gas fees and not about to waste any more to troubleshoot the issue. Using Chrome and Metamask.

1 Like

Try refreshing the page on Rarible, Try putting your Ethereum address in search bar of opensea.io to see if your NFT’s images show up there. Try using another browser like the Vivaldi Browser.

Yes Eth gas prices are very very high at the moment they were only a couple of dollars a month age, maybe wait till they drop if you have to remint. They have been over $100 last week, should be lower when ethV2 is fully implemented soon.Don.t waste money on high gas prices .I don’t buy anything when gas prices are more than a few dollars. Download an Eth Gas Price app.Not a lot of selling happening at the moment on rarible https://opensea.io/activity/rarible?search[isSingleCollection]=true

They do not have images, just the Rarible logo:


Maybe contact support support@rarible.com

Check transaction on Ethscan to see if still pending.

I had contacted support last night, and also a Rarible person had responded to my tweet overnight saying they’d look into it. Looks like now they’ve been resolved, although now I have 2 of the same piece on my profile bc I retried a mint that seemed to have broke.

OK thanks for letting me know.

You could burn the item you don’t want but you will have to pay an eth fee, which is usually smaller than a normal gas fee that you pay for minting a token.

I have been having issues submitting artwork… during the mint process it errors. I also noticed on first attempt the fee price shows about 60$ eth and then after it errors I try again and it shows 4$ eth… not sure what is going on but have already wasted $ trying to submit for almost the past week now… support hasn’t responded yet either I contacted fortmatic and they of course said contact rarible…

1 Like

Got a direct response from Alex on twitter. They had an issue with a 3rd party storage provider, good thing I didn’t burn the tokens last night. They resolved gradually this morning, first on Rarible, then the changes appeared on OpenSea.

Although now I have a duplicate of an NFT I thought failed last night that I tried to recreate. That will probably still need to burn being that I claim it’s 1/1, but will wait for gas fees to die down.

1 Like

I had the exact same issue yesterday :worried:
…Is there a way to get those ETH back?

Just had that happen to me. Did you find out what went wrong?