Minting problem - no title or image, just broken image icon

Yesterday I minted my first NFT on Rarible, no problem. Today I tried to mint another one, paid the gas fee and signed Metamask. On my profile page, where information and a thumbnail of the just minted item should be it says ‘untitled’ - I gave it a title - and a broken’ icon.

How do I go about getting this corrected?

(upload error)
(can’t upload screen shot showing the problem)

my profile page is: https://rarible.com/the_artist_cass?tab=owned

…very strange…the screen shot images I tried to upload produced errors messages instead of showing the screen shot but when I posted the images appeared…

Hi @cass

Sometimes, the blockchain is slow. Wait several hours.

Mahalo Sheratan, I’ll give it some time

1 Like

If it’s the Agave one then I’m seeing it

A lot of the success in this game is patience and research and your question, which is a valid one for a first-timer, had been asked and answered dozens of times so please use the search bar here and in YT

Good luck with it all :slightly_smiling_face:

1 Like

Thanks for the tip, and yes I should have spent a little more time search on it. I don’t spend as much time on forums as I use because of social networks, but I learned back then search on forums was often not very effective. And thanks for encouraging comment too. :call_me_hand:
BTW, are you aware of ‘underlay awareness’ issues with P2P networks?

1 Like